Đang Thực Hiện

159426 Review / Debug 1 AS function

I have a flash "filmstrip nav" fla that takes an sub array of a master array containing external jpgs and passes that array to a function to "populate" the film strip with the images that then do an "endless scroll" of those images.

On the first "load", it works perfectly no matter how large the array.

On each additional call with another "sub array set", I am left with a "gap" in the strip = to 600 pix.

Example:

1st call, pass 5 element array, strip scrolls in endless loop as wanted.

2nd call, pass 5 element array, strip has the now 10 picts + blank pictures = 600 pix ( each is 60 pix high )

3rd call, pass 5 element array, strip has the now 15 pics + 1200 pix blank .

etc

I believe it has to do with the instance of the "container" and currently have a "case" in the function as I try to solve this but no change.

I need someone to look at this one function and fix it to be truly "re-entrant" capable.

Thank you.

*Please* , ONLY seasoned pro's for this.

Should be quick and easy for an experienced pro.

Kỹ năng: Adobe Flash, Bất kì công việc gì

Xem thêm: function, first review, call review, call function, scroll fix, nav container, flash load external images, additional function, external additional images, fix debug, quick function, film fix, container load, Review film, load container, experienced pro, filmstrip, master flash, 1st call, flash master, easy populate master, images flash scroll, flash pics loop, film strip images, fix easy populate

Về Bên Thuê:
( 44 nhận xét ) Ramona, United States

Mã Dự Án: #1905615